[Debian] Actualización Debian Etch a Lenny

Ayer me puse a actualizar uno de mis ordenadores de Debian Etch a Debian Lenny, aprovechando que ésta última está congelada para corregir errores antes de ser estable.

Tras cambiar “etch” por “lenny” en el archivo /etc/apt/sources.list y ejecutar “apt-get update && apt-get upgrade && apt-get dist-upgrade” me dio un error, despues de haber descargado toda la actualización (4 horas en mi conexión ADSL).

El error consistia en un fallo en las dependencias y que no podía desinstalar “gs-common”. Tras lo cual, no permite instalar nada ni hacer nada más.

Para desinstalar gs-common primero se comenta o se borra la línea “set -e” en /var/lib/dpkg/info/gs-common.prerm

Luego se ejecuta: dpkg –purge –force-all gs-common
Se ejecuta: apt-get -f install
Y se ejecuta otra vez: apt-get dist-upgrade

Finalmente, se finaliza la actualización. En mi caso, tuve que repetir los dos últimos comandos con el programa “cupsys”.

CC BY-SA 4.0 This work is licensed under a Creative Commons Attribution-ShareAlike 4.0 International License.